Enemy AI gets stuck on geothermal station

Please come here to inform us of new and interesting bugs so we can hunt them down and destroy them! Pics and videos demonstrating these bugs are also welcome!
Post Reply
User avatar
SirKnum
Beta Tester
Beta Tester
Posts: 32
Joined: Sun May 14, 2017 5:40 pm
Location: Germoney

Enemy AI gets stuck on geothermal station

Post by SirKnum » Sun Aug 06, 2017 10:02 am

Version 15.1 / Windows 10

I do not exactly know how the planet type is called, the decription on the science panel just says "WARNING: HIGH TEMP". It is the geothermal station station that is inhabited by robot bandits. Two spawn outside in front of the door where the teleporter is and then there is a bunch of them inside.

In earlier versions they would wait behind the door for you but now they seem to all spawn in the same place on the lower level and get stuck. They do shoot at you once they see you but they never move. They did this on every single planet of this type I encountered.

http://i.imgur.com/C4JPJZK.jpg

This is the lower floor opposite to the elevator. If you approach from the side like I did here they do not attack, if you have a go at them frontally they do attack.

User avatar
cptslog
Leafy Developer
Leafy Developer
Posts: 1050
Joined: Sun Sep 08, 2013 9:08 pm

Re: Enemy AI gets stuck on geothermal station

Post by cptslog » Mon Aug 07, 2017 1:27 pm

Thanks for the report and screenshot

We'll do some testing and look into it shortly

User avatar
Tom R
Beta Tester
Beta Tester
Posts: 30
Joined: Wed Jan 04, 2017 9:39 pm

Re: Enemy AI gets stuck on geothermal station

Post by Tom R » Mon Aug 07, 2017 1:35 pm

This still happens in 15.2. The Metal Bandits at the door are sometimes visible but eventually end up in the stack downstairs. The door bots sort of teleport away once you get close enough.

Post Reply