Inaccurate Component Upgrade Window

Please come here to inform us of new and interesting bugs so we can hunt them down and destroy them! Pics and videos demonstrating these bugs are also welcome!
Post Reply
justinjah91
Posts: 68
Joined: Thu Jan 12, 2017 12:22 am

Inaccurate Component Upgrade Window

Post by justinjah91 » Mon Jul 30, 2018 10:46 pm

----------------------------
Bug Report
----------------------------
OS: Windows 10
Game Version: Beta 19.2
Date and Time Encountered (DD/MM/YY, HH:MM (12h format)): 30/07/18, 09:38 PM CDT
----------------------------
Possible Conflicting Software (such as firewalls and anti-virus): None
Severity: Moderate
Description of Bug: Some components do not have accurate upgrades listed in the upgrade window. I was looking at the upgrade for the focused laser turret on my WD Destroyer when I noticed this. The upgrade window has a bit of a formatting issue, but as far as I can tell it is showing a downgrade, not an upgrade.

Steps to Reproduce: Try upgrading a focused laser turret. I'm not sure if this is the same on every ship or just the destroyer.
----------------------------
Screenshots and/or Video: https://imgur.com/a/dXOerfS
----------------------------
Notes:
  1. I eventually got enough scrap to upgrade the focused laser turret. It seems that this bug is just a problem with the interface. The turret itself was upgraded from 202 damage to 221.
  2. I think I've figured it out. The display lists your current weapon's stats with all bonuses (talents, destroyer perks, etc) included. The upgrade only lists the base stats. As a result, the upgrade can be lower than the original weapon because it is not accounting for the destroyer's +20% turret damage or turret damage bonuses from talents.
----------------------------
Hardware Configuration:

CPU: Intel i5
GPU: NVidia GTX 750
RAM: 8GB
Motherboard: Asus
HDD: Seagate 500 GB HDD
SSD: Seagate 500 GB SSD
----------------------------

User avatar
Edinstein
Leafy Developer
Leafy Developer
Posts: 994
Joined: Sun Sep 08, 2013 10:39 pm

Re: Inaccurate Component Upgrade Window

Post by Edinstein » Thu Aug 02, 2018 8:45 am

Ah, thanks for the information! that's an interesting find! I imagine we'll either need to remove those passive bonuses or apply them to the upgrade result. Thanks again!

Post Reply