Issues loading a saved game [RESOLVED]

Please come here to inform us of new and interesting bugs so we can hunt them down and destroy them! Pics and videos demonstrating these bugs are also welcome!
Post Reply
CaptSmokey6
Posts: 4
Joined: Fri Sep 14, 2018 2:06 am

Issues loading a saved game [RESOLVED]

Post by CaptSmokey6 » Fri Sep 14, 2018 3:36 am

----------------------------
Bug Report
----------------------------
OS: Windows 10 Pro Version 10.0.17134
Game Version: 19.4
Date and Time Encountered: 13/09/18, 11:00 pm MST (UTC-7):
----------------------------
Possible Conflicting Software (such as firewalls and anti-virus): None
Severity: Urgent & Severe
Description of Bug:

Game saves fail to load, it just goes back to the main menu after a few minutes on the loading screen. Immediately upon starting a new game after the failed attempt to load a game save, I would get placed in a random sector, could be a sector with a battle ongoing or a sector with a planet, yet the home location still shows on the map, "home location" being the Estate for AOG, Outpost 448 for CU, or WD Hub for WD. Not shown in the video below is loading a game save on the "Game Over" screen doesn't work either. Upon exiting the "glitched" session and loading a new game again, it'll load at the proper home location, but upon disconnecting and attempting to load a game save again, the same problems as stated above reoccur.

Steps to Reproduce:
Described above.

Possible Workaround:
Unknown or None.
----------------------------
Screenshots and/or Video:
https://youtu.be/ucXUyQnq8k8
----------------------------
Notes: None
----------------------------
Hardware Configuration:

CPU: Intel Core i7 950 (Bloomfield)
GPU: NVIDIA GTX 1060
RAM: 24 GB
Motherboard: GA-X58A-UD3R
HDD: Two 1 TB HDDs
SSD: One 250 GB SSD and one 240 GB SSD
----------------------------
Last edited by CaptSmokey6 on Wed Sep 26, 2018 12:25 am, edited 1 time in total.

User avatar
Edinstein
Leafy Developer
Leafy Developer
Posts: 994
Joined: Sun Sep 08, 2013 10:39 pm

Re: Issues loading a saved game

Post by Edinstein » Fri Sep 14, 2018 11:45 am

Hey CaptSmokey6

Sorry for the trouble, we can't seem to replicate the issue right now on our end. Do you mind sending us one of the save files that you loaded? (email: team@leafygames.com )

Also, do you continue to encounter issues if you start a new crew directly after booting the game?

Thanks for the report, we'll be looking into it!

CaptSmokey6
Posts: 4
Joined: Fri Sep 14, 2018 2:06 am

Re: Issues loading a saved game

Post by CaptSmokey6 » Fri Sep 14, 2018 10:19 pm

Hi Edinstein, I have sent the save file i made, along with a few autosaves from the same session. As for your other question, as long as I don't attempt to load any of my saves, I can start a new crew directly without a problem. I did made a video recording of the issue and I included a link to it in the bug report above.

gundpiltb
Posts: 1
Joined: Sat Sep 15, 2018 2:34 am

Re: Issues loading a saved game

Post by gundpiltb » Sat Sep 15, 2018 5:48 am

We had the same problem tonight. We loaded the game from an old (19.3) save file just fine and saved over it a few times over the next few hours. We screwed up our reputations, so we decided to reload the most recent manual save (pre-screwing up) and found that it wouldn't load in the exact same manner as CaptSmokey6 described

----------------------------
Bug Report
----------------------------
OS: Microsoft windows 10 home
Game Version: 19.5 (steam version)
Date and Time Encountered 15/09/18, 00:30
----------------------------
Possible Conflicting Software (such as firewalls and anti-virus): none
Severity: severe
Description of Bug: when loading save file, game gets stuck on loading for a while then aborts to main menu.
Steps to Reproduce: Load a pre-19.5 (19.4 in our case) save file, save over it whilst in 19.5, then load that new save file
----------------------------
Screenshots and/or Video: https://cdn.discordapp.com/attachments/ ... oading.png when hitting "engage" to load game, it gets stuck on this screen before going back to main menu.
----------------------------
Notes: none
----------------------------
Hardware Configuration:

CPU: Intel core i5-4670k 3.40HGz
GPU: AMD Radeon HD 6870
RAM: 8GB DDR3
Motherboard: Asus Z87
----------------------------

CaptSmokey6
Posts: 4
Joined: Fri Sep 14, 2018 2:06 am

Re: Issues loading a saved game

Post by CaptSmokey6 » Wed Sep 26, 2018 12:24 am

The issue seems to be resolved on version 19.6, thanks for fixing it, devs! :)

Post Reply