Page 1 of 1

Engineer bot auto jumping to random sectors

Posted: Sun Oct 29, 2017 5:24 pm
by SimaShi
Hello,

Earlier I was playing a game with a friend. He was captain, I was pilot, and we had bots filling the other roles. I noticed that if the ship has been prepared for warp, and I align the ship to any sector, we will auto jump to that sector. This is nice if we have aligned to the correct sector in the path set by the captain, but not good if I'm aligned to some other sector on my way to rotating to the correct dot.

Is this making any sense? Does anyone know why this might be happening? The only fix we found is not letting the engineer bot jump the ship, which means we have to.

Oddly enough, I was playing with another friend (I was captain, he was pilot) and this was never an issue. Am I doing something wrong as pilot?

Re: Engineer bot auto jumping to random sectors

Posted: Tue Oct 31, 2017 12:12 pm
by Edinstein
Sounds like the previous host didn't update their AI priorities or they edited the defaults. Previous versions of the game had the priority but it wasn't functioning. If they didn't update and had a high base importance the behavior you described is entirely possible. If you reset AI priorities to their defaults, the engbot should only ever jump to a sector targeted by the captain. Which sounds like what you mentioned when you were the captain.

Hope this helps!

Re: Engineer bot auto jumping to random sectors

Posted: Mon Nov 13, 2017 1:23 pm
by Mr. Morague
Alternatively, this could be because of a confusion between priorities. If I remember correctly, there is one where the engineer will jump as soon as a sector is available, and one only when the ship lines up with a targeted sector, or the ones with the two blue circles around them.