Page 1 of 1

Touch Joystick head turning on Oculus?

Posted: Thu Apr 12, 2018 3:30 am
by evilebob
How do I increase the rate that my head can turn via Oculus touch joystick?
This ridiculously slow turn rate is causing discomfort and at this stage the game is unplayable for me.

Re: Touch Joystick head turning on Oculus?

Posted: Thu Apr 12, 2018 12:57 pm
by Edinstein
We currently don't have an in-game option for this but if you're willing you can open the bindings file (usually WordPad does a good job formatting it) and change the setting yourself!

You'll want to scroll down until you see something like this:

<controller name="Oculus Touch" enabled="true">
<category name="Basics">
<action name="Move Vertical" id="joystick_move_vertical">
<axis id="3" device="LTouch" type="oculusvr" sensitivity="0.5" multiplier="1" clamp="false" deadzone="0.05" invert="false" offset="0" />
</action>
<action name="Move Horizontal" id="joystick_move_horizontal">
<axis id="2" device="LTouch" type="oculusvr" sensitivity="0.5" multiplier="1" clamp="false" deadzone="0.05" invert="false" offset="0" />
</action>
<action name="view x" id="joystick_view_x">
<axis id="2" device="RTouch" type="oculusvr" sensitivity="0.1" multiplier="1" clamp="false" deadzone="0.05" invert="false" offset="0" />
</action>
<action name="view y" id="joystick_view_y">
<axis id="3" device="RTouch" type="oculusvr" sensitivity="0.1" multiplier="1" clamp="false" deadzone="0.05" invert="false" offset="0" />
</action>

I've colored the values you want to change to red. Try changing them to 0.2. Save and reload the game. If that's still too slow you can bump it up further. Just be careful not to raise it too high too quickly! (motion sickness and all).

The same technique would also work for Steam VR if anyone is curious.

Re: Touch Joystick head turning on Oculus?

Posted: Sat Apr 14, 2018 11:54 pm
by evilebob
tyvm,
very excited to give this another try!

Re: Touch Joystick head turning on Oculus?

Posted: Thu Apr 26, 2018 11:37 am
by evilebob
I've tested and it works but only if I lock down the file as readonly.
For some reason the file gets re-written each time the game is launched.

Re: Touch Joystick head turning on Oculus?

Posted: Fri Apr 27, 2018 6:37 pm
by Edinstein
That's odd, it shouldn't be doing that unless there's an outdated bindings file. Just to be sure, are you editing while the game is launched? If you like, you can also send us your bindings file and we can take a look. You can email it to us here: team@leafygames.com

Re: Touch Joystick head turning on Oculus?

Posted: Sat Apr 28, 2018 2:28 am
by evilebob
Emailed and attaching to thread in case anybody else ventures these paths...

to team
this is from thread (http://forums.pulsarthegame.com/viewtop ... f=7&t=4160)
I've attached two bindings files. One older than the other and both readonly.
What I'm noticing now is that after a few days when I launch the game my touch controllers are no longer the default input devices.. ie can't select menu items. I disabled readonly on the bindings file and on next launch it was re-written with the 0.1 values. I edited to 1 and relaunched but value was again reset to 0.1. I edited and locked to readonly and was able to play again.
Day or two later I relaunched but again no touch input. So bindings file was invalid by age or something... So for now I have to allow it to be changed to 0.1 and re-edit before playing.
Both attachment files are essentially identical except the game wouldn't accept one over the other even though it did accept it at one point.
Taken from \SteamLibrary\SteamApps\common\PULSARLostColony