Bugs in warp drive programs

Please come here to inform us of new and interesting bugs so we can hunt them down and destroy them! Pics and videos demonstrating these bugs are also welcome!
Post Reply
skynigh
Posts: 9
Joined: Mon Sep 17, 2018 7:15 pm

Bugs in warp drive programs

Post by skynigh » Fri Sep 28, 2018 9:51 pm

----------------------------
Bug Report
----------------------------
OS:Windows 10
Game Version:19.6
Date and Time Encountered 9-27-18
----------------------------
Possible Conflicting Software (such as firewalls and anti-virus): None
Severity: low

CPU:AMD-FX-8320
GPU:Nvidia Geforce GTX 750
RAM:16 GB
Motherboard: GA-78LMT
HDD:(2) 1 TB hard drives
SSD:NONE
----------------------------


Shut down defenses lists disables defenses for 10 sec but once infected the countdown timer infects for 360 secs https://i.imgur.com/5gskScc.png
this occurs if drones or enemy ships infect you with the virus
the countdown timer for the virus is 10 sec though

Sitting duck
runs active for 60 sec and has a infected time of 40 sec so the time listed is for the program run time not the program active time
https://i.imgur.com/EaUA0w9.png

Syber Shield has the same effect in that the listed active time countdown is at 90 and the infection time is really high at 360s
even though it says the active time is for 90 secs
https://i.imgur.com/on9nUNT.png

Armor flaw is the exact same way as shutdown shields active timer is 30 secs but once infected there it last for 360 secs
https://i.imgur.com/BQnyHwR.png


Over Drive
this virus works as it should but it displays the % incorrectly as i have a base of 90 + 50 more should be 140 not 185 https://i.imgur.com/EsqF1im.png


Shield recharge rate
component displays at a increased rate of 10% per level when used to hover over this it is correct but on the ships side where it says shield charge rate on the bottom it displays incorrectly added roughly 40%-50% per level instead of the roughly 10%
https://i.imgur.com/4XBqhqb.png
this happens with every shield as far as i can tell


me and a group of folks run a lot of different ship builds and we notice a lot of things

EngBot
Posts: 8
Joined: Thu Sep 27, 2018 6:15 pm

Re: Bugs in warp drive programs

Post by EngBot » Fri Sep 28, 2018 10:42 pm

the math for the +% thing just appears to be based of the reactor at level 1

the +90% is due to to the reactor being level 10, 90% better then a level 1

then you get 50% of the 43,700 current reactor or 21,850 from the program

43,700 + 21,850 = 65,550 or 150% percent of your level 10 reactors normal power

the +185% is again based of the level 1 version of the reactor

your Roland Reactor at level 1: 23000 MW
185% of 23000 is 42,550
23,000 + 42,550 = 65,550

User avatar
Tom R
Beta Tester
Beta Tester
Posts: 30
Joined: Wed Jan 04, 2017 9:39 pm

Re: Bugs in warp drive programs

Post by Tom R » Fri Sep 28, 2018 11:49 pm

Eng's math is correct, so the real issue is we expect the green number to account for temporary buffs (like programs), not both temporary and permanent increases from level. The number makes sense once you know the context, but most people I've talked to misunderstand it at first. Temporary differences only would probably make it more intuitive.

User avatar
cptslog
Leafy Developer
Leafy Developer
Posts: 927
Joined: Sun Sep 08, 2013 9:08 pm

Re: Bugs in warp drive programs

Post by cptslog » Wed Nov 14, 2018 2:09 pm

Thanks for the report, sorry for the issues

Some of these should be fixed in Beta 20. I'll look into the others shortly!

Post Reply