Poly Tech ship issues

Please come here to inform us of new and interesting bugs so we can hunt them down and destroy them! Pics and videos demonstrating these bugs are also welcome!
Post Reply
FloppyDisk
Posts: 34
Joined: Thu Mar 11, 2021 6:14 pm

Poly Tech ship issues

Post by FloppyDisk » Sat Apr 24, 2021 4:54 am

Hello Leafys,
Here is the post about the mesh and ship issues that you where threatened with :)

Shooting on ship and planet does not leave bullet decals and causes exceptions
(this also happens on the planet)
Image

reactor - you can see the back side of the reactor wall where there is missing texture
Image

Image

Missing mesh on screens
Image

Image

Image

Image

Image

Image

bridge light missing mesh
Image

Turrets floating
Image

Image

Interceptor style door locking doodads show through wall and clip lights
Image

Image

Piloting can not be entered from certain positions
Image

Image

Image
FloppyDisk | Storage Media

FloppyDisk
Posts: 34
Joined: Thu Mar 11, 2021 6:14 pm

Re: Poly Tech ship issues

Post by FloppyDisk » Sat Apr 24, 2021 8:32 pm

also
pls remove
Image

if you have to have the screens on the ship just move them outside the ship.

I would also like to say I really like how the ship turned out, it is very cool. You guys have done a very good job on it. I saw it last update before it was finished and I really like how it has turned out.
Thanks for making this game, It has been lots of fun to play
FloppyDisk | Storage Media

User avatar
Edinstein
Leafy Developer
Leafy Developer
Posts: 1204
Joined: Sun Sep 08, 2013 10:39 pm

Re: Poly Tech ship issues

Post by Edinstein » Wed Apr 28, 2021 4:50 pm

Most of these should be fixed now!

We're still looking into the piloting issue.

As for removing the Oxygen Gen and Air Filter option from view. We considered this, but we opted to keep them in solely for the fact that players can double-check they are off. For example, some player's might have AI priorities where bots may turn them back on and the players might have no way of knowing.

Hope that clarifies our thoughts on this!

FloppyDisk
Posts: 34
Joined: Thu Mar 11, 2021 6:14 pm

Re: Poly Tech ship issues

Post by FloppyDisk » Thu Apr 29, 2021 12:54 am

Edinstein wrote:
Wed Apr 28, 2021 4:50 pm
Most of these should be fixed now!

We're still looking into the piloting issue.

As for removing the Oxygen Gen and Air Filter option from view. We considered this, but we opted to keep them in solely for the fact that players can double-check they are off. For example, some player's might have AI priorities where bots may turn them back on and the players might have no way of knowing.

Hope that clarifies our thoughts on this!
This seems like a work around for the fact that bots do not actually use the in game controls.

there is already an optimize for bot method in PLEngineeringScreen. could you not add in there to stop bots from touching those controls then in one of the update methods just check if its enabled then toggle to off.

To me these controls should not be in the ship as the ship does not have those systems.
FloppyDisk | Storage Media

FloppyDisk
Posts: 34
Joined: Thu Mar 11, 2021 6:14 pm

Re: Poly Tech ship issues

Post by FloppyDisk » Mon May 03, 2021 3:28 am

also these doors are now not centered.
suggestion is to swap the doors
Image
FloppyDisk | Storage Media

Rama
Posts: 45
Joined: Tue Nov 28, 2017 9:34 am

Re: Poly Tech ship issues

Post by Rama » Mon May 03, 2021 3:29 am

Hello Leafys,
Floppy forgot to mention this.
Image

All the screens on the interceptor are physical screens, not floaty screens. The only exception is the research screen. And thus it looks a bit naked and out of place. It is not really a bug, but a design concern.

Other issue is a mesh that is too much.
Image
This little really cool design element is perfectly placed there. But it should not have mesh. The others don't and it is sufficiently tiny. And here it just causes the issue that the scientist gets stuck when trying to rush over to the sensor screen when hugging the station during combat.
Thank you!

FloppyDisk
Posts: 34
Joined: Thu Mar 11, 2021 6:14 pm

Re: Poly Tech ship issues

Post by FloppyDisk » Mon May 03, 2021 3:30 am

Rama wrote:
Mon May 03, 2021 3:29 am
Hello Leafys,
Floppy forgot to mention this.
Image

All the screens on the interceptor are physical screens, not floaty screens. The only exception is the research screen. And thus it looks a bit naked and out of place. It is not really a bug, but a design concern.

Other issue is a mesh that is too much.
Image
This little really cool design element is perfectly placed there. But it should not have mesh. The others don't and it is sufficiently tiny. And here it just causes the issue that the scientist gets stuck when trying to rush over to the sensor screen when hugging the station during combat.
Thank you!
I suggest to use the same surrounding as the extractor screen
Image
FloppyDisk | Storage Media

Post Reply